[Metadatalibrarians] OpenRefine LCSH reconciliation troubleshooting

Casey Mullin casey at mullingroup.com
Thu Apr 26 11:24:10 PDT 2018


I used to have moderate success with the LCSH recon. service (as recently as several months ago), but the AAT service always gave me the wheel of death.

Good luck,


Casey A. Mullin

(pronouns: he/him/his)

Head of Cataloging and Metadata Services
Western Washington University Libraries

Managing Partner
Flourish Music Metadata Solutions

Past Chair
Music OCLC Users Group

E-mail address for Flourish business: musicmetadatasolutions at gmail.com<mailto:musicmetadatasolutions at gmail.com>
E-mail address for all other business: casey at mullingroup.com<mailto:casey at mullingroup.com>

From: Metadatalibrarians <metadatalibrarians-bounces at lists.monarchos.com> on behalf of Amber Billey <abilley at bard.edu>
Sent: Thursday, April 26, 2018 11:09 AM
To: metadatalibrarians at lists.monarchos.com
Subject: [Metadatalibrarians] OpenRefine LCSH reconciliation troubleshooting

Hi Everyone,

I've recently had issues using trying to reconcile terms against LCSH using
OpenRefine. I set up the reconciliation service following the instructions
laid out on the Free Your Metadata site (
https://nam03.safelinks.protection.outlook.com/?url=http%3A%2F%2Ffreeyourmetadata.org%2Freconciliation%2F&data=02%7C01%7C%7Cfebdef5c82124307e44e08d5aba10223%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636603630363694810&sdata=wv6Yrfq1uArNVyPYuxYzr1uoQOne3%2FNJy45ShcdTrqk%3D&reserved=0). Then when I try to actually
reconcile a column of terms using the reconciliation service that I set up,
I just get a spinning wheel of death and the program freezes. No progress
bar and no reconciliation.

I'm running OpenRefine 2.8

With the latest RDF Extension

I've tried running the reconciliation service on a PC running Windows 7 and
Windows 10, and I've tried it on a Mac. Still the same spinning wheel and
program freezing.

I used to be able to successfully run this reconciliation service, and
munged much metadata using it. But for some reason it's not working
anymore. Could it be the SPARQL endpoint?

Is anyone else having these issues?

Is anyone successfully using OpenRefine to reconcile against LCSH? If so,
what SPARQL endpoint are you using?

Many thanks,

Amber Billey (she/her/hers)
Systems & Metadata Librarian
Bard College Libraries
1 Library Road
Annandale-on-Hudson, NY 12504
Metadatalibrarians mailing list
Metadatalibrarians at lists.monarchos.com

More information about the Metadatalibrarians mailing list